Incident Report for MyWebsite Now
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Oct 11, 2021 - 13:16 EDT
Identified
Some customers may be experiencing issues accessing their websites.
Posted Oct 11, 2021 - 11:00 EDT
This incident affected: Website Builder and Hosting (MyWebsite NOW).