Upcoming HiDrive Maintenance
Incident Report for ionos.com
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 07, 2018 - 01:23 EST
Monitoring
We will be performing maintenance on our HiDrive product between 8:00 p.m. to 9:00 p.m. on November 6, 2018. During this time, you may experience connectivity issues with your HiDrive accounts, so please plan accordingly.

We sincerely apologize for any inconvenience this may cause you.
Posted 3 months ago. Nov 06, 2018 - 09:31 EST
This incident affected: Email & Office (HiDrive).