Purchased products maybe delayed during setup
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Nov 06, 2019 - 11:37 EST
Identified
Due to a technical disruption, recent purchases of products may be delayed during setup
Posted Nov 06, 2019 - 06:19 EST
This incident affected: Contract Management (Contract Activation).