Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 3 months ago. Apr 02, 2019 - 06:08 EDT
Identified
Due to a techncial issue with our Support Tools, our Customer Service Team may not be able to answer all questions related to your account.
Posted 3 months ago. Apr 02, 2019 - 06:02 EDT
This incident affected: Customer Service (Support Tool).