Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 6 months ago. Jan 31, 2019 - 17:01 EST
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 6 months ago. Jan 31, 2019 - 17:00 EST
This incident affected: Customer Service (Support Tool).