Greater hold time in our Hotline
Incident Report for ionos.com
Resolved
The disruption affecting the Support Hotline has been resolved. It is now functioning normally again.
Posted 2 months ago. Dec 11, 2018 - 11:03 EST
Update
We are continuing to work on a fix for this issue.
Posted 2 months ago. Dec 11, 2018 - 10:06 EST
Identified
An outage with one of our main offices are causing problems with our Technical Support line. You may experience a greater hold time than usual. We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding.

Please reach our customer care unit via e-mail at support@ionos.com
Posted 2 months ago. Dec 11, 2018 - 10:05 EST
This incident affected: Customer Service (Customer Hotline).