Incident Report for Customer Service Support Tool
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Dec 09, 2021 - 09:13 EST
Identified
We are experiencing technical issues within our Customer Service Support Tool. Contacting our support through E-Mail may result in some delays. Additionally, our Customer Service Team may not be able to answer all questions related to your account. We apologize for any inconvenience this may cause you.
Posted Dec 09, 2021 - 08:55 EST
This incident affected: Customer Service (Support Tool).