Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 3 months ago. Mar 20, 2019 - 04:54 EDT
Identified
Our Customer Service might also not be able to answer all questions related to your account. We apologize for any inconvenience this may cause you.
Posted 3 months ago. Mar 20, 2019 - 04:47 EDT
This incident affected: Customer Service (Support Tool).