Upcoming HiDrive Maintenance
Incident Report for ionos.com
Resolved
This incident has been resolved.
Posted 3 months ago. Nov 02, 2018 - 05:49 EDT
Investigating
We will be performing maintenance on our HiDrive product between 10:00 P.M. to 12:00 A.M est . on November 1, 2018. During this time, you may experience connectivity issues with your HiDrive accounts, so please plan accordingly.

We sincerely apologize for any inconvenience this may cause you.
Posted 3 months ago. Nov 01, 2018 - 07:16 EDT
This incident affected: Email & Office (HiDrive).