Support Hotline cannot be reached
Incident Report for ionos.com
Resolved
The issue has been resolved. We apologize for the inconvenience caused and thank you for your patience.
Posted Jul 28, 2020 - 06:48 EDT
Identified
We are experiencing technical issues within Ionos Phone Systems. Your call may not be answered. We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding. We will continue to post updates as we make progress on these issues. 


Please reach our customer care unit via e-mail at support@ionos.com
Posted Jul 28, 2020 - 03:24 EDT
This incident affected: Customer Service (Customer Hotline).