Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted 27 days ago. Mar 28, 2019 - 10:50 EDT
Identified
Due to a techncial issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 27 days ago. Mar 28, 2019 - 09:35 EDT
This incident affected: Customer Service (Support Tool).