Disruption in logging into the Webmail
Incident Report for ionos.com
Resolved
Webmail issue has been resolved.

We apologize for the inconvenience caused.
Posted 3 months ago. Mar 27, 2019 - 10:34 EDT
Identified
We have received reports that some of our customers are experiencing issues when attempting to log into Webmail.
Posted 3 months ago. Mar 27, 2019 - 09:37 EDT
This incident affected: Email & Office (Webmail).