Incident Report for Webmail
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted May 19, 2020 - 02:16 EDT
Identified
Some customers may face issues while using their Webmail
Posted May 18, 2020 - 13:55 EDT
This incident affected: Email (Webmail).