Incident Report
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted 4 months ago. Apr 16, 2019 - 15:12 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 4 months ago. Apr 16, 2019 - 14:35 EDT
This incident affected: Customer Service (Support Tool).