Incident report for MyWebsite
Incident Report for ionos.com
Resolved
This incident has been resolved.
Posted Jun 18, 2020 - 17:08 EDT
Identified
Some customers may experience issues with elements on the website
Posted Jun 18, 2020 - 16:55 EDT
This incident affected: Website Builder and Hosting (MyWebsite (ordered before 09/06/2017)).