Disruption in logging into the Outlook Web App

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Aug 19, 2025 - 13:25 EDT

Identified

We have received reports that some customers may be experiencing login issues with their Exchange2019 email address via the Outlook Web App.
Posted Aug 19, 2025 - 12:34 EDT
This incident affected: Email (Microsoft Exchange).