Sending e-mail to Microsoft hosted email address may not be possible
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jan 26, 2021 - 16:46 EST
Update
We are still working on resolving the technical issue. Thank you for your patience.
Posted Jan 26, 2021 - 09:41 EST
Update
Email sent to Microsoft hosted email addresses may be rejected due to Microsoft blocking some of our IP addresses.

We are in contact with Microsoft to request de-listing.

Please accept our apologies for any inconvenience caused.
Posted Jan 25, 2021 - 07:10 EST
Identified
We have received reports that some of our customers may be experiencing issues when sending emails to Microsoft
Posted Jan 23, 2021 - 03:03 EST
This incident affected: Mail System and Delivery (Sending Emails).