Sending e-mail to Microsoft hosted email address may not be possible
Incident Report for ionos.com
Resolved
The issue has been resolved. We apologize for the inconvenience caused and thank you for your patience.
Posted May 13, 2021 - 08:23 EDT
Identified
We have received reports that some of our customers may be experiencing issues when sending emails to Microsoft
Posted May 12, 2021 - 14:49 EDT
This incident affected: Mail System and Delivery (Sending Emails).