Support Hotline cannot be reached
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Oct 29, 2020 - 09:11 EDT
Identified
Due to a technical disruption, the Support hotline is temporarily unavailable. Please call us back later or send us an E-mail to support@ionos.com
Posted Oct 29, 2020 - 08:47 EDT
This incident affected: Customer Service (Customer Hotline).