Unable to update payment method
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted Jun 12, 2024 - 12:05 EDT
Update
We have found the cause for the disruption and are working on resolving it.
Posted Jun 12, 2024 - 11:35 EDT
Identified
Some customers may not be able to update their payment method. We apologize for any inconvenience this may cause you.
Posted Jun 12, 2024 - 10:50 EDT
This incident affected: Customer Service (Support Tool) and Contract Management (Billing Service).