Incident Report for Email Marketing Software
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jul 19, 2023 - 06:56 EDT
Update
We have eliminated the disruption for almost everyone affected.
Posted Jul 19, 2023 - 06:32 EDT
Identified
Due to a technical disruption, accessing Email Marketing Software is not possible at this time.
Posted Jul 19, 2023 - 06:03 EDT
This incident affected: Online Marketing (E-Mail Marketing).