Incident Report for List Local
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Mar 17, 2021 - 07:33 EDT
Identified
Some customers may face issues while using their List Local.
Posted Mar 17, 2021 - 06:28 EDT
This incident affected: Online Marketing (ListLocal).