Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 14 days ago. Aug 09, 2019 - 06:16 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 14 days ago. Aug 09, 2019 - 05:33 EDT
This incident affected: Customer Service (Support Tool).