Technical issues in our email systems
Incident Report for ionos.com
Resolved
The issue has been resolved. Our apologies for the inconvenience caused.
Posted May 07, 2024 - 11:15 EDT
Identified
We have eliminated the disruption for almost everyone affected.
Posted May 07, 2024 - 10:40 EDT
Investigating
Due to a technical issue, some customers may not be able to access their emails by email client.
Posted May 07, 2024 - 07:28 EDT
This incident affected: Email (Webmail).