Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted 2 months ago. May 12, 2019 - 12:21 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted 2 months ago. May 12, 2019 - 11:52 EDT
This incident affected: Customer Service (Support Tool).