Sending emails may not be possible for some customers

Incident Report for ionos.com

Resolved

This incident has been resolved.
Posted Aug 13, 2026 - 16:04 EDT

Identified

Some customers may be experiencing issues sending E-mails.
Posted Aug 13, 2026 - 15:17 EDT
This incident affected: Email (Microsoft Exchange).