Sending e-mail to Microsoft 365 email address may be delayed
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted May 27, 2021 - 12:24 EDT
Identified
We have received reports that some of our customers may be experiencing issues when sending emails to Microsoft 365 email address.
Posted May 26, 2021 - 06:06 EDT
This incident affected: Mail System and Delivery (Sending Emails).