Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Mar 03, 2020 - 02:04 EST
Identified
Some customers may experience issues while using their Backup Console
Posted Mar 02, 2020 - 11:57 EST
This incident affected: Servers (Cloud Server).