Domain order and DNS technical disruption
Incident Report for ionos.com
Resolved
This incident has been resolved.
Posted Oct 14, 2020 - 08:17 EDT
Identified
Due to a technical disruption some Customers may experience delays in domain configuration.
Posted Oct 14, 2020 - 06:34 EDT
This incident affected: Domains (DNS) and Contract Management (Order Page).