Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved. Thank you for your patience and understanding.
Posted Oct 03, 2021 - 22:44 EDT
Identified
Due to a technical disruption, recent purchases of products may be delayed during setup.
Posted Oct 03, 2021 - 10:18 EDT
This incident affected: Contract Management (Contract Activation).