Incident Report for MyWebsite Now

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Apr 16, 2025 - 15:39 EDT

Identified

Some customers may face issues while using their MyWebsite product. At this time, it may not be possible to use the website editor. The online websites that have already been created may also be affected.
Posted Apr 16, 2025 - 14:58 EDT
This incident affected: Website Builder (MyWebsite NOW).