Cancellation may not be possible

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Aug 19, 2024 - 07:17 EDT

Identified

Due to a technical disruption, cancellation of products or features may not be possible at this time.
Posted Aug 19, 2024 - 06:13 EDT
This incident affected: Contract Management (Cancellation Service).