Incident Report for webmail
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted Nov 12, 2021 - 11:15 EST
Identified
Some customers may face issues while using their webmail
Posted Nov 12, 2021 - 10:42 EST
This incident affected: Email (Webmail).