Incident Report for HiDrive
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted Feb 18, 2020 - 11:08 EST
Update
Our technicians are currently working on resolving this issue.
Posted Feb 17, 2020 - 12:19 EST
Identified
We have received reports that some of our customers may be experiencing issues when attempting to log into HiDrive
Posted Feb 15, 2020 - 19:40 EST
This incident affected: Online Storage & Backup (HiDrive).