Incident Report for ionos.com
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again. We apologize for the inconvenience caused and thank you for your patience.
Posted May 10, 2021 - 18:29 EDT
Identified
We are experiencing technical issues with our website ionos.com
Posted May 10, 2021 - 14:00 EDT
This incident affected: Contract Management (Order Page).