Limited functionality of product Webmail
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jul 09, 2020 - 09:26 EDT
Identified
Some customers may face issues while using their Webmail.
Posted Jul 09, 2020 - 07:30 EDT
This incident affected: Email (Webmail).