Access to E-Mail & Office in the Control Panel may be temporarily restricted
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jun 29, 2020 - 03:13 EDT
Identified
Access to E-Mail & Office in the Control Panel may be temporarily restricted. We are currently working on resolving the technical disruption. We will have an update for you shortly.
Posted Jun 29, 2020 - 03:07 EDT
This incident affected: Control Panel.