Incident Report for Customer Service Support Tool
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Sep 22, 2022 - 05:16 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Sep 22, 2022 - 04:50 EDT
This incident affected: Customer Service (Support Tool).