Incident Report for Customer Service Support Tool
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jul 26, 2023 - 07:09 EDT
Identified
Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Jul 26, 2023 - 06:28 EDT
This incident affected: Customer Service (Support Tool).