Email address creation may not be possible
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Aug 23, 2021 - 08:04 EDT
Identified
Some customers may be experiencing issues creating email address.
Posted Aug 23, 2021 - 06:53 EDT
This incident affected: IONOS (IONOS Control Panel).