Invoices are not able to be viewed in the Control Panel.

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Nov 11, 2023 - 11:02 EST

Identified

Some customers are unable to view their invoice in the Control Panel. Our technicians are currently working on resolving this issue.
Posted Nov 11, 2023 - 10:28 EST
This incident affected: Contract Management (Billing Service).