Limited functionality of Support Tools

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Nov 22, 2023 - 06:12 EST

Update

We are still working on resolving the technical issue. Our apologies for the inconvenience caused.
Posted Nov 22, 2023 - 04:16 EST

Update

Our technicians are currently working on resolving this issue.
Posted Nov 21, 2023 - 12:13 EST

Identified

Due to a technical disruption, cancellation of products or features may not be possible at this time.
Posted Nov 21, 2023 - 11:05 EST
This incident affected: Customer Service (Support Tool).