Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jul 21, 2021 - 01:20 EDT
Identified
Some customers may be experiencing issues in updating their payment information
Posted Jul 20, 2021 - 13:09 EDT
This incident affected: Contract Management (Billing Service).