Limited functionality of Support Tools

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Jan 24, 2024 - 12:44 EST

Identified

Due to a technical issue with our Support Tools, our Customer Service might not be able to answer all questions related to your account.
Posted Jan 24, 2024 - 12:31 EST
This incident affected: Customer Service (Support Tool).