Technical issues in our email systems

Incident Report for ionos.com

Resolved

The issue has been resolved. We apologize for the inconvenience caused and thank you for your patience.
Posted Aug 07, 2024 - 14:14 EDT

Update

We have eliminated the disruption for some of those affected.
Posted Aug 07, 2024 - 14:03 EDT

Update

We have found the cause for the disruption and are working on resolving it.
Posted Aug 07, 2024 - 12:39 EDT

Update

We are still working on resolving the technical issue.
Posted Aug 07, 2024 - 12:16 EDT

Identified

Currently, there are issues in our email systems. In case of problems with your mail software, we recommend you to use the webmail on https://mail.ionos.com/ . Due to the increased number of users, it may be necessary to reload the webmail during use.
Posted Aug 07, 2024 - 11:37 EDT
This incident affected: Email (Mail client).