Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Mar 03, 2020 - 08:12 EST
Identified
Some customers may experience issues while using their Backup Console
Posted Mar 03, 2020 - 03:10 EST
This incident affected: Servers (Cloud Server).