Greater hold time in our Hotline
Incident Report for ionos.com
Resolved
The systems are stable and all services are functioning normally again.
Posted Sep 14, 2022 - 22:29 EDT
Identified
We are experiencing technical issues within Ionos Phone Systems. Your call may not be answered. We apologize for any inconvenience during these brief technical difficulties and appreciate your patience and understanding. We will continue to post updates as we make progress on these issues. 


Please reach our customer care unit via e-mail at support@ionos.com
Posted Sep 14, 2022 - 17:45 EDT
This incident affected: Customer Service (Customer Hotline).