Limited functionality of Webspace Recovery
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Mar 25, 2020 - 09:56 EDT
Update
We are still working on resolving the technical issue.
Posted Mar 24, 2020 - 17:48 EDT
Identified
Some customers may face issues while using Webspace Recovery.
Posted Mar 24, 2020 - 14:25 EDT
This incident affected: Website Builder and Hosting (Web Hosting).