Placing orders is temporarily not possible

Incident Report for ionos.com

Resolved

The issue has been resolved.
Posted Jul 26, 2023 - 07:14 EDT

Identified

Some customers may be experienceing isues when ordering products.
Posted Jul 26, 2023 - 06:30 EDT
This incident affected: Contract Management (Contract Activation).