Incident Report
Incident Report for ionos.com
Resolved
The issue has been resolved.
Posted Jul 12, 2022 - 11:45 EDT
Update
We have found the cause for the disruption and are working on resolving it.
Posted Jul 12, 2022 - 10:30 EDT
Update
We are still working on resolving the technical issue. Thank you for your patience.
Posted Jul 12, 2022 - 09:28 EDT
Identified
Some customers may face issues while using their Microsoft Exchange 2019.
Posted Jul 12, 2022 - 09:00 EDT
This incident affected: Email (Microsoft Exchange).